Cómo solucionar la Vulnerabilidad por Malware en PrestaShop


Vulnerabilidad Malware PrestaShop

Vulnerabilidad Malware PrestaShop

Recientemente, se ha descubierto una vulnerabilidad para las tiendas de PrestaShop 1.6 y 1.7 que ha sido notificada por Francis Ladeuil. Ésta puede utilizarse para tener acceso a toda una tienda online y controlarla a través de malware, por lo que debemos prestarle la atención que merece.

Desde Línea Gráfica hemos desarrollado este módulo que te permitirá comprobar la vulnerabilidad de tu tienda y eliminar la amenaza. Si quieres saber más sobre este malware y el módulo, continúa leyendo.

Solucionar la Vulnerabilidad

Vulnerabilidad de seguridad en PrestaShop

Los atacantes están explotando una vulnerabilidad en PHPUnit con códigos arbitrarios en servidores que ejecutan sitios web de PrestaShop para poder controlar la página al completo. Todas las versiones anteriores a PHPUnit 7.5.19 y 8.5.1 son vulnerables.

¿Qué puede pasar si un atacante accede a tu sitio web? Puede robar tus datos y los de tus clientes, perjudicando tu integridad como empresa y tus resultados. Por ello, es importante comprobar si hay un directorio llamado «phpunit» en el FTP de nuestra tienda online, que es, como hemos dicho, el que vuelve vulnerable nuestro sitio web a este malware. Se trata de una biblioteca de desarrollo y no es necesaria para el funcionamiento normal del sitio web, por lo que eliminarlo es la mejor opción para prevenir el ataque.

Módulo comprobador de vulnerabilidad PHPUnit

Para poder comprobar si tu sitio web es vulnerable a estos ataques, en Línea Gráfica hemos desarrollado un módulo comprobador de vulnerabilidad PHPUnit PrestaShop 1.6 y 1.7 que te permitirá analizar todos los archivos de esta librería (phpunit) y te dará la opción de eliminarlos definitivamente. Acabando con la posible amenaza. Esta tarea puede hacerse manualmente, pero si tienes muchos módulos puede ser un proceso muy lento, por ello es recomendable utilizar este nuevo módulo de Línea Gráfica.

¿Cómo funciona el módulo comprobador de vulnerabilidad PHPUnit? Se encarga de escanear de forma automática todos los directorios posibles de PrestaShop y todos aquellos módulos que tengamos instalados, en busca de la librería PHPUnit. Tras esta búsqueda, nos proporciona un listado con todas las librerías encontradas, dándonos la opción de eliminarlas. Es importante destacar que se trata de un módulo de distribución gratuita.

Si no se encuentra ningún módulo que contenga la carpeta “phpunit”, tu tienda no es vulnerable a este tipo de ataques.

Tienda online comprometida

Aunque realicemos este análisis y eliminemos los directorios que vuelven vulnerable nuestro sitio web, es posible que nuestra tienda online ya se haya visto comprometida. La mayoría de los atacantes colocan archivos o modifican otros ya existentes; esta será nuestra forma de comprobar si nuestro sitio web está siendo o ha sido atacado.

Compruebe minuciosamente que el atacante no ha dejado ningún archivo en el servidor. A través del artículo que presenta PrestaShop sobre esta vulnerabilidad de la seguridad del sitio web, destacamos el siguiente listado de archivos problemáticos que puede incluir una tienda online comprometida:

  • XsamXadoo_Bot.php
  • XsamXadoo_deface.php
  • 0x666.php
  • f.php
  • Xsam_Xadoo.html

En caso de duda, cambie las contraseñas de todos los usuarios administrativos de su tienda y considere pedir a sus clientes que hagan lo mismo, pero recuerde asegurarse previamente a través de nuestro módulo comprobador de vulnerabilidad PHPUnit de que no haya ningún archivo comprometido en la tienda para evitar un nuevo ataque.

Módulos PrestaShop afectados

Según este artículo que mencionábamos antes, existen varios módulos que se ven afectados por esta vulnerabilidad:

  • Actualización con 1 clic: versiones 4.0 beta y posteriores
  • Cart Abandonment Pro: versiones 2.0.1 ~ 2.0.2
  • Búsqueda por facetas: versiones 2.2.1 ~ 3.0.0
  • Experiencia del comerciante: versiones 2.1.0 y posteriores
  • PrestaShop Checkout: versiones 1.0.8 ~ 1.0.9

PrestaShop ha lanzado nuevas versiones de los módulos afectados en las que elimina totalmente la biblioteca con la que se relaciona esta amenaza y vulnerabilidad que serían: v4.10.1, v2.0.10, v3.4.1, v2.3.2 y v1.2.9, respectivamente según el listado anterior.

Aunque debemos recordar que, si en algún momento hemos instalado las anteriores versiones comprometidas, probablemente seguiremos teniendo en nuestro servidor los archivos PHPUnit, por lo que es importante que los eliminemos, ya que no sirve con instalar las versiones actualizadas sin más.

Acciones de PrestaShop

Ante esta situación, PrestaShop ha llevado a cabo distintas acciones sobre esta vulnerabilidad. Por ello, todos los socios han sido informados y deberían haber asegurado concienzudamente las tiendas que controlan. Además, los módulos afectados han sido actualizados para volverlos seguros, como veíamos en el punto anterior.

Desde PrestaShop están comprobando todos los módulos para asegurarse de si contienen o no la mencionada carpeta vulnerable “phpunit”.

La seguridad de tu tienda es lo más importante para nosotros, te ayudamos a reducir el impacto y amenaza de malware. Echa un vistazo al resto de módulos de PrestaShop que te proporcionamos en Línea Gráfica y mantén las amenazas lejos de tu sitio web. Además, podrás mejorar tus opciones como tienda online.

1 Estrella2 Estrellas3 Estrellas4 Estrellas5 Estrellas (2 valoraciones, media: 5,00 de 5)
Cargando…