Módulo Comprobador de vulnerabilidad PHPUnit Prestashop 1.6 y 1.7


  • email: demo@demo.com
  • password: demodemo
Módulo Comprobador de vulnerabilidad PHPUnit Prestashop 1.6 y 1.7

El módulo ayuda a eliminar una vulnerabilidad notificada en Enero 2020 de las tiendas Prestashop 1.6.x y 1.7.x, debido a que en ocasiones se usa bien en módulos de terceros o en el propio núcleo por la inclusión la librería PHPUnit que en versiones anteriores a 7.5.19 y 8.5.1 contienen un fallo que pueden explotar para conseguir ejecutar cualquier código con el consiguiente peligro de robo de datos, etc. Nuestro módulo buscará los archivos de esta librería y permitirá eliminarlos.

 

mockup_pack_LGSecurity
COMPATIBLITY Prestashop v1.6.x - v.17.x
DESARROLLADO POR Logo Linea Gráfica
PRECIO
Gratis

FUNCIONALIDADES

¿CÓMO FUNCIONA?

El módulo escanea, siempre que sea posible, todos los directorios de componentes del núcleo de PrestaShop y módulos instalado en busca de la librería PHPUnit.  Saca un listado de las librerias encontradas y da la posibilidad de eliminarlo.

Desde LINEA GRAFICA E.C.E. S.L. no podemos garantizar el correcto funcionamiento del módulo debido a la gran variablidad existente en las tiendas prestashop y por tanto no se hace responsable de su uso.

Prestashop da más información sobre esta vulnerabilidad en: https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules/

 

 

Este módulo es de distribución gratuita y por tanto no lleva soporte incluido.