• email: demo@demo.com
  • password: demodemo
Module de Vérification de vulnérabilité PHPUnit Prestashop 1.6 et 1.7

Le module permet d’éliminer une vulnérabilité signalée en janvier 2020 dans les magasins Prestashop 1.6.x et 1.7.x, car il est parfois utilisé soit dans des modules tiers ou dans le noyau lui-même en incluant la bibliothèque PHPUnit que dans les versions antérieures à 7.5.19 et 8.5.1 contiennent un défaut qui pourrait être exploité pour exécuter n’importe quel code avec le danger conséquent de vol de données, etc. Notre module recherchera les archives de cette bibliothèque et vous permettra de les supprimer.

 

mockup_pack_LGSecurity
COMPATIBILITÉ Prestashop v1.6.x - v1.7.7.8
DÉVELOPPÉ PAR Logo Linea Gráfica
PRIX
Gratuit

CARACTÉRISTIQUES

COMMENT ÇA MARCHE?

Le module analyse, dans la mesure du possible, tous les répertoires des composants principaux de PrestaShop et les modules installés à la recherche de la bibliothèque PHPUnit. Prenez une liste des bibliothèques trouvées et donnez la possibilité de la supprimer.

De LINEA GRAFICA E.C.E. S.L. ne peut garantir le bon fonctionnement du module en raison de la grande variabilité des magasins prestashop et n’est donc pas responsable de son utilisation.

Prestashop donne plus d’informations sur cette vulnérabilité à: https://build.prestashop.com/news/critical-security-vulnerability-in-prestashop-modules/

Ce module est distribué gratuitement et n’a donc pas de support inclus.